[实践OK]centos 6升级 GCC 到4.8 ,GCC 4.8 or later required。 不指定

jackxiang 2019-1-9 16:27 | |
想打包一个swoole最新版,出现 问题如下:


解决办法:
安装最新版本的swoole 提示

pecl install swolle
...
GCC 4.8 or later required.
首先想到的时候yum更新gcc

yum install gcc
Package gcc-4.4.7-23.el6.x86_64 already installed and latest version
Nothing to do
已经是最新版本了,怎么办,只有找其它源了

curl -Lks http://www.hop5.in/yum/el6/hop5.repo > /etc/yum.repos.d/hop5.repo
yum install gcc gcc-g++
安装成功

gcc -v
gcc version 4.8.2 20131212 (Red Hat 4.8.2-8) (GCC)


来自:https://my.oschina.net/2688/blog/2933883

作者:jackxiang@向东博客 专注WEB应用 构架之美 --- 构架之美,在于尽态极妍 | 应用之美,在于药到病除
地址:http://jackxiang.com/post/10040/
版权所有。转载时必须以链接形式注明作者和原始出处及本声明!

评论列表
发表评论

昵称

网址

电邮

打开HTML 打开UBB 打开表情 隐藏 记住我 [登入] [注册]